Resolved
Timeout (> 30s)

Started
February 25, 2022 at 11:34 PM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    February 25, 2022 at 11:35 PM

    cakemail.com is now operational!