Resolved
Timeout (> 30s)

Started
April 06, 2022 at 1:51 AM
Status
Resolved after less than a minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 06, 2022 at 1:51 AM

    cakemail.com is now operational!