Resolved
Timeout (> 30s)

Started
April 06, 2022 at 8:01 PM
Status
Resolved after less than a minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 06, 2022 at 8:01 PM

    cakemail.com is now operational!