Resolved
Timeout (> 30s)

Started
April 09, 2022 at 1:21 AM
Status
Resolved after 2 minutes
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 09, 2022 at 1:23 AM

    cakemail.com is now operational!