Resolved
Timeout (> 30s)

Started
April 17, 2022 at 1:04 PM
Status
Resolved after less than a minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 17, 2022 at 1:04 PM

    cakemail.com is now operational!