Resolved
Timeout (> 30s)

Started
April 22, 2022 at 10:14 PM
Status
Resolved after 2 minutes
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 22, 2022 at 10:16 PM

    cakemail.com is now operational!