Resolved
Timeout (> 30s)

Started
April 26, 2022 at 8:13 PM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 26, 2022 at 8:14 PM

    cakemail.com is now operational!