Resolved
Timeout (> 30s)

Started
July 12, 2022 at 7:54 PM
Status
Resolved after 3 minutes

Impact

Major outage
Affected
cakemail.com
  • Resolved
    July 12, 2022 at 7:57 PM

    cakemail.com is now operational!