Resolved
Timeout (> 30s)

Started
August 15, 2022 at 5:44 PM
Status
Resolved after less than a minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    August 15, 2022 at 5:44 PM

    cakemail.com is now operational!