Resolved
Timeout (> 30s)

Started
August 16, 2022 at 2:42 PM
Status
Resolved after 1 minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    August 16, 2022 at 2:43 PM

    cakemail.com is now operational!