Resolved
Timeout (> 30s)

Started
August 18, 2022 at 8:24 AM
Status
Resolved after 1 minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    August 18, 2022 at 8:25 AM

    cakemail.com is now operational!