Resolved
Timeout (> 30s)

Started
August 24, 2022 at 5:01 AM
Status
Resolved after less than a minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    August 24, 2022 at 5:01 AM

    cakemail.com is now operational!