Resolved
Timeout (> 30s)

Started
September 13, 2022 at 4:23 PM
Status
Resolved after 1 minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    September 13, 2022 at 4:24 PM

    cakemail.com is now operational!