Resolved
Issue with email delivery

Started
June 16, 2023 at 11:58 AM
Status
Resolved after about 1 hour

Impact

Operational
Affected
Cakemail Email Delivery Infrastructure
  • Resolved

    The issue has now been resolved

  • Identified

    We have identified the issue and we are currently working on fixing this

  • Investigating

    We are currently investigating this incident.