Resolved
HTTP Error 503

Started
September 04, 2023 at 5:39 AM
Status
Resolved after 2 minutes

Impact

Major outage
Affected
Cakemail.com
  • Resolved
    Resolved

    Cakemail.com is now operational!