Resolved
HTTP Error 502

Started
October 03, 2023 at 2:02 AM
Status
Resolved after 1 minute

Impact

Major outage
Affected
Cakemail.com
  • Resolved
    Resolved

    Cakemail.com is now operational!