Resolved
HTTP Error 504

Started
November 12, 2023 at 11:11 PM
Status
Resolved after less than a minute

Impact

Major outage
Affected
Cakemail.com
  • Resolved
    Resolved

    Cakemail.com is now operational!