Resolved
HTTP Error 503

Started
January 19, 2023 at 11:05 PM
Status
Resolved after 3 minutes

Impact

Major outage
Affected
cakemail.com
  • Resolved
    January 19, 2023 at 11:08 PM

    cakemail.com is now operational!