[Resolved] Timeout (> 30s)

Started on December 30, 2021 at 8:20 PM. Resolved after less than a minute

Affected

cakemail.com
  • Resolved
    December 30, 2021 at 8:20 PM

    cakemail.com is now operational!