Resolved
Timeout (> 30s)

Started
January 28, 2022 at 12:07 AM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Major outage
  • Resolved
    January 28, 2022 at 12:08 AM

    cakemail.com is now operational!