Resolved
Timeout (> 30s)

Started
February 06, 2022 at 10:11 PM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    February 06, 2022 at 10:12 PM

    cakemail.com is now operational!