Resolved
Timeout (> 30s)

Started
February 25, 2022 at 5:26 AM
Status
Resolved after 4 minutes
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    February 25, 2022 at 5:30 AM

    cakemail.com is now operational!