Resolved
Timeout (> 30s)

Started
March 02, 2022 at 2:38 PM
Status
Resolved after 2 minutes
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    March 02, 2022 at 2:40 PM

    cakemail.com is now operational!