Resolved
Timeout (> 30s)

Started
April 04, 2022 at 6:41 PM
Status
Resolved after 2 minutes
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 04, 2022 at 6:43 PM

    cakemail.com is now operational!