Resolved
Timeout (> 30s)

Started
April 20, 2022 at 3:18 PM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 20, 2022 at 3:19 PM

    cakemail.com is now operational!