Resolved
Timeout (> 30s)

Started
April 22, 2022 at 6:17 PM
Status
Resolved after 1 minute
Affected
cakemail.com

Impact

Degraded performance
  • Resolved
    April 22, 2022 at 6:18 PM

    cakemail.com is now operational!