Resolved
Timeout (> 30s)

Started
November 22, 2022 at 10:17 AM
Status
Resolved after less than a minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    November 22, 2022 at 10:17 AM

    cakemail.com is now operational!