Resolved
HTTP Error 502

Started
January 19, 2023 at 11:00 PM
Status
Resolved after 1 minute

Impact

Major outage
Affected
cakemail.com
  • Resolved
    January 19, 2023 at 11:01 PM

    cakemail.com is now operational!