[Resolved] HTTP Error 503

Started on December 21, 2021 at 9:12 PM. Resolved after 12 minutes

Affected

cakemail.com
  • Resolved
    December 21, 2021 at 9:24 PM

    cakemail.com is now operational!